速度が満足に出ない光回線でも、IPv6接続とv6プラスを使えば、十分な速度が出るという。ただ、この方式ではサーバー公開ができない。そのため導入を見送っていたが、PPPoEと同時に使用できるとわかり、導入に踏み切った。幸い、契約しているビッグローブ光は追加料金無しで利用できる。対応しているルーターを準備して、申込みを済ませるだけでいい。

ルーターの選択

ひかり電話ルーターはないので、市販のルーターを使う。プロバイダのページに書かれているv6プラス対応のルーターはBuffaloとIO DATAの機種。他にはASUSやヤマハのルーターが対応しているらしい。ASUS製は色々出来るが、安定性は疑問。IO DATAは安いものの、最近出たばかりで落ち着いていない。ヤマハは高いので除外。値段が手頃で対応機種の多いBuffaloにした。

BuffaloでもWXRで始まる機種だけが対応している。サポートの長い現行機を選ぶ。WXR-2533DHP2、WXR-1900SHP3、WXR-1750DHP2の3機種。無線の性能は重視しないのでWXR-1750DHP2でいいが、価格差があまりないのでデュアルコアのWXR-1900DHP3を購入した。

v6プラスの申し込み

開通の案内にあるお客様IDが必要になる。v6プラスを申し込みたいところだが、申し込む必要があるのは「フレッツ光 IPv6接続」。先にフレッツ光 IPv6接続を申し込む必要がある。IPv6接続の設定完了メールが来たら、v6プラスが使えるようになる。v6プラスを申し込む。特に連絡もなく使えるようになるしばらくので、先にルーターの設置を進める。v6プラスに申し込めるようになるが、申し込むとv6プラスが無効になるので注意が必要。

ルーターのセットアップ

本体裏側をスイッチをAUTOからMANUALに切り替える。切り替えないと自分でv6プラスを選べない上に、ルーターの配下に繋ぐとアクセスポイントとして動作してしまう。新しいルーターは既存のネットワークに追加して使った。既設のルーターのIPv6ブリッジの設定を有効にしておく。VDSLモデム(またはONU)-ルーター(PPPoE)-ルーター(v6プラス)-PCの構成にした。PPPoEとv6プラスのルーターは逆でも問題ない。

設置したらルーターの管理画面をブラウザで開く。ログインしたら詳細設定を選ぶ。Internetの設定で「v6プラス接続を使用する」にチェックを入れ設定。IPv6の設定はIPパススルーは危険なのでNDプロキシを選択。無線やLANなどの設定をする。ポート変換は設定しない。

設定完了

設定が完了してしばらくすると前面のLEDが全て点灯する。これで新しく設置したWXR-1900DHP3に繋いだ端末はv6プラスで通信できるようになった。ただ、現状では既存のPPPoEルーター配下のネットワークとの通信はできない。今回は同じセグメントに置くとうまくいかなかったので分けた状態で設定した。ここからサーバーを通じて相互に通信できるようにする。

参考

おすすめ


7月 18th, 2017

Posted In: ネットワーク

タグ: , , ,

Leave a Comment

Debianをsqueezeにアップグレードして以降、DiCEでお名前.comのIPアドレス更新がうまくいってなかった。放っておいたらルーターの再接続でIPアドレスが変わってしまい問題になった。表示されたメッセージは「Error: サーバーに接続できませんでした」。

調べてみるとOpenSSLのライブラリへのシンボリックリンクが必要ということなので、下の記事を参考に作業してみた。

DiCEのインストール完了! | てきとーな日々を

#locate libssl.so
#locate libcrypto.so
で、ライブラリを探し、シンボリックリンクを張る
# ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0
# ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0
これでOK
あとはDiCEを実行すれば、IP更新できる・・・はず

書いてある通りにやってみたが、同じ環境なのに動かなかった。

ふと、64bitOSということを思い出して、32bitのライブラリにリンクしてみた。

$ sudo ln –s /usr/lib32/libssl.so.0.9.8 /usr/lib/libssl.so.0

この後試すとIPアドレスの更新に成功した。libcrypto.soはリンクしなくてもお名前,comは動いた。

同じ64bitなのに同じ方法でなぜ動かないのかわからない。それにlennyの時は何もしなくても動いた。

おすすめ


3月 7th, 2011

Posted In: ソフトウェア

タグ: , , , ,

One Comment

今使ってる様子のおかしいルーターはNECのWR8500N。熱で壊れたと思うけど、それでも完全に切れないのはcoregaと大違い。家庭用ルーターは相変わらずNECが鉄板なので次もNECにする。

候補に上がるのはWR8700NとWR8300N、どちらも有線1Gbps、WR8500Nと違ってJumboFrame対応。WR8500Nは上位機種のWR8700Nと値段が変わらないので候補にしない。両方WPA2対応でサブSSIDのネットワーク隔離に対応している。WR8500Nにほしかった機能だからうれしい。今まではWEPのサブSSIDが隔離できないため無効にしていた。

WR8700Nにすると性能が上がって、多機能になる。無線はa/b/g/n同時利用でアンテナは4本。今まではa/n・b/g/n切り替えだった。ただし家にはa対応機器がない。USB機能もあるが、ファイルサーバーがあるので使わない。

WR8300Nにすると有線性能はほぼそのまま。無線はアンテナが3つから2つになるが、150Mbpsの無線しかないため影響は少ない。a/nも同じ。消費電力はWR8500Nより少ない。(=熱の発生少ない)熱暴走も少ないはず。

WR8700NでもWR8500N買った値段より安いが、値段差は4000円程度。それほど利点がないのでWR8300Nを注文した。

おすすめ


8月 10th, 2010

Posted In: ネットワーク

タグ: , , , ,

Leave a Comment

メインPC以外でサーバー上の動画にアクセスすると遅くて見れるものでなかった。以前は普通に見れていた。サーバーを確認するとサーバーのNIC1つに異常が見られたので、別のNIC使うようにして解決した.。が、動画の再生は改善しなかった。試しにメインPCからルーターにpingをしてみるとロスが少し出ていた。どこかがおかしい。

家のネットワークは次の構成
ONU→ルーター→20m有線→スイッチングハブ→メインPC・サーバー
ONU→ルーター→無線→ノートPC

サーバーからメイン以外のPCの経路は
PC→無線→ルーター→20m有線→スイッチングハブ→サーバー

有線で直接ルーターにつないでも改善しなかった。
異常の原因とみられるのは

  • スイッチングハブの異常
  • ケーブルが悪い
  • ルーターの異常

問題を切り分ける。サーバー上の動画が見れるか確認する。

スイッチングハブはメインPCで異常が出ていないし、そこにノートPCにつないでも異常が出なかった。ポートを変えても改善しなかった。ハブの可能性は低い。

ルーターかケーブルかを切り分ける。ルーターに差さってるケーブルにノートPCをつなぎ、ルーターのIPを振って試してみた。ノートPCをつなぐと改善した。またルーターにつなぐと速度が下がった。
ルーターが原因ということが分かった。

ルーターを再起動しても初期化しても改善しなかった。保証が切れてるので新しいルーターの購入を検討する。

追記:
ルーターを変更しても復旧せず、ハブの故障と判明。

おすすめ


8月 9th, 2010

Posted In: ネットワーク

タグ: , ,

Leave a Comment